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CH-1 COMPUTER LANGUAGE
Exercises
A. 1. Program, 2. Four, 3. Machine,
4. Ada Lovelace, 5. High level,
6. Assembly, 7. Syntax, 8. Off, on.
B. 1. True, 2. True, 3. True, 4. False, 5. False,
6. False, 7. True, 8. False.
C. 1. (b), 2. (c), 3. (c), 4. (b).
D. 1. A computer language includes various
languages that are used to communicate
with a computer machine. Some of the
languages like programming language
which is a set of codes or instructions
used for communicating the machine.
Machine code is also considered as a
computer language that can be used for
programming.
2. All the languages that are now available
can be classified into the following
categories: Machine language, Assembly
language, High-level language and
Fourth generation language.
Assembly Language : Assembly
Language is the second generation
programming language that has
almost similar structure and set of
commands as machine language.
Instead of using numbers in Machine
Language here we use words or
names in English forms and also
symbols. The programs that have
been written using words, names and
symbols in assembly language are
converted to machine language using
a Assemble. Because a computer only
understands machine code languages
that's why we need a Assembler that
can convert the Assembly language to
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Machine language. So, that the
computer gets the instruction and
responds quickly.
3. The high level languages are the most
used and also more considered
programming languages that helps a
programmer to read, write and
maintain. It is also the third generation
language that is used and also running
till now by many programmers. They
are less independent to a particular
type of computer and also require a
translator that can convert the high
level language to machine language.
The translator may be an interpreter
and compiler that helps to convert into
binary code for a computer to
understand. There is various high level
programming languages like C,
FORTRAN or Pascal that are less
independent and also enables the
programmer to write a program.
4. Interpreter : High Level Language
programs need to be translated into
machine language by using the
translator programs. This translator
program is used to convert a high level
language program into machine
language. An interpreter translates line
by line, executes the instruction and
then repeats the procedure for the
remaining instructions. If any errors
are found, they are to be removed
immediately. As the converted form is
not stored anywhere, so it has to be
generated at the time of execution of a
program. Interpreter programs are
preferred for beginners and are slow in
execution speed.
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Compiler : It plays an important role
on the computer as it can convert to
machine language and also checks for
errors if any before executing. There
are several high level languages that
were used earlier and also now like
COBOL, FORTRAN, BASIC, C, C++,
PASCAL, LISP, Ada, Algol, Prolog and
Java. It is user friendly as the programs
are written in English using words,
symbols, characters, numbers that
need to be converted to machine code
for processing.
5. Fourth generation languages are
combination of languages with the
following features:
v Highly user-friendly and independent
of any operating system.
v Very high speed of execution. Designed
to reduce the level of programming
efforts.
v Designed to reduce the overall time
it takes to develop software and the
cost of software development. In
4GL, the user has to specify only the
required output they want, while the
computer determines the sequence
of instructions that will accomplish
those results.
E. 1. Mohit's uncle used high level language.
2. Java is an object oriented language. Its
syntax is common as C and C++. Java
programs are compiled to byte code.
CH-2 MORE ON WINDOWS 10
Exercises
A. 1. Organize, 2. Copying, 3. Fonts,
4. Disk Cleanup, 5. Continuum.
B. 1. True, 2. True, 3. False, 4. False, 5. True.
C. 1. (a), 2. (b), 3. (b).
D. 1. Windows Media Player is a media
player and media library applicator
developed by Microsoft that is used for
playing audio, video and viewing
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images on personal computer running
the Microsoft Windows Operating
System, as well as on pocket PC and
windows Mobile based devices.
2. Ripping : We can copy songs from our
favorite music CDs/DVDs onto our
computers with Windows Media
Player. When we rip music, we are
actually copying songs from a CD to
computer. After the songs have been
copied to our computer, we can use
Windows Media Player to play and
organize the songs, create play lists,
and copy music to a portable device.
Burning : When you create a CD or
DVD, you must tell your PC running
Windows 10 what you are copying and
where you interned to play it: Music
for CD player? Photo Slide shows for
TV's DVD player? or files to share on
your computer?
3. Microsoft Windows Hello is a
biometric identify and access control
feature that supports fingerprint
scanners, iris scanners and facial
recognition technology. Biometric
logins are secure, fast, and easy to
create. Windows Hello requires
appropriate hardware devices to be
connected to the system for its
proper working.
4. To create a new desktop, follow the
steps given below:
v Click on the button situated on the
taskbar. The Task View Task View
Pane opens and displays the preview
of all the open windows.
v Click on the New desktop button
located at the bottom-right corner of
the Task View Pane. A new desktop
thumbnail named 'Desktop 2'
appears.
v Click on the thumbnail to view the
newly created desktop. It is a replica
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of Desktop 1 but doesn't display the
applications opened in Desktop 1.
You can open the apps that you want
to use on this desktop. You can group
the desktop windows by opening
similar kind of apps in one desktop.
v Click on the Task View button again
to switch between desktops.
5. Disk cleanup is a Microsoft Software
utility first introduced with Windows
98 and included in all subsequent
releases of windows. It enables us to
remove files that are no longer needed
or that can be safely deleted. Removing
unnecessary files, including temporary
files, can help to speed up and improve
the performance of the computer.
E. 1. Rohit need to perform Burn Files to a
Disc option to burn his favorite songs
to a CD.
2. 'Windows Hello' feature of
Windows10 can help Deepak to make
his system secure through biometric
login. Because Microsoft Windows
Hello is a biometric identify and
access control feature that supports
fingerprint scanners, iris scanners and
facial recognition technology.
Biometric logins are secure, fast, and
easy to create.
CH-3 FLOWCHARTS AND PROGRAMS
Exercises
A. 1. Diagram, 2. Start/Stop, 3. Processing,
4. Fortran, 5. Java.
B. 1. (a), 2. (a), 3. (b), 4. (b), 5. (c).
C. 1. (a), 2. (a), 3. (a), 4. (c)
D. 1. A flowchart is a type of diagram that
represents an algorithm, workflow or
process, showing the steps as boxes of
various kinds and their order by
connecting them with arrows. This
diagrammatic representation
illustrates a solution model to a given
problem. Flowcharts are used in
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analyzing, designing, documenting or
managing a process or program in
various fields.
2. A flowchart imparts all information
visually by using standard symbols to
represent these different functions. It
uses arrows to represent the sequence
in which the instructions should be
performed.
3. Start/Stop Symbol: This symbol is
used to show where your flow begins or
ends.
Input/Output Symbol: This symbol is
used to indicate the acceptance of
inputs from a user or the output or the
result concluded.

Flow Lines: The flowchart symbols are
connected with the help of flow lines.

Processing Symbol: The symbol is
used to illustrate a process, action or an
operation.

Decision Box: The symbol is used in a
process flow to as a question. And the
answer to the question determines the
arrows coming out of the symbol.

Connector: In flowcharts, this symbol
is typically small and is used as a
connector to show a jump from one
point in the process flow to another.

4. Advantages of flowcharts :
v Communication: Flowcharts are better
way of communicating the logic of a
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system to all concerned or involved.
v Effective Analysis: With the help of

D. 1—(b), 2—(a), 3—(b).
E. 1. No I will not write it directly. Because
a program can be viewed as an
elaborate algorithm. In mathematics
and computer science, an algorithm
usually means a small procedure that
solves repetitive problem. So I use
flow chart to write a program.
2. Yes, we can solve many problems of our
daily by using algorithm and flowchart.
We can put available resources in
planned way with the help of flowchart
and get maximum results which help
us to reduce the upcoming problems.
My Activity

flowchart, problem can be analysed
in more effective way therefore
reducing cost and wastage of time.
v Proper Documentation: Program
flowcharts save as a good program
documentation, which is needed for
various purposes, making things
more efficient.
Disadvantages of Flowcharts:
v Complex logic: Sometimes, the
program logic is quick complicated. In
that case flowchart becomes complex
and clumsy. This will become a pain for
the user, resulting in a waste of time.
Q B A S I C F B
v Alterations and Modifications: If
E A L G R G B A
alternations are required the
D F O R T R A N
flowchart may require re-drawing
A E G H I T S S
completely. This will usually waste
P D O C Q R I J
valuable time.
O W C B V U C X
v Reproduction: As the flowchart
J A V A C F A Z
symbols cannot be typed, reproduction
A N M L K Y C ++
of flowchart becomes a problem.
5. a. This flowchart depict the conversion CH-4 MORE ON MS POWERPOINT 2016
Exercise
of Celsius to Fahrenheit.
b. 2°C = 35.6°F, 10°C = 50°F
A. 1. Transitions, 2. Text, objects,
6.
3. Microphone, 4. From Beginning,
Start
5. Loop until Stopped.
B. 1. True, 2. True, 3.False, 4. True,
5. False, 6. True.
Read A, B, C
C. 1. (b), 2. (b), 3. (c), 4. (a).
D. 1. Moving objects, such as text, graphics,
charts, logos, etc. that are made up of a
S=A+B+C
sequence of images displayed after this
A = S/3
other on the slide are called Animations.
P=A*B*C
Animation is quite helpful when you
want to focus on important points. It
also controls the sequence of the flow
Print S, A, P
of information and helps in making
information more extraordinary.
Apart from giving visual effects to your
Stope
presentation, you can also sizzle up
your slide objects – the text, pictures,
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shapes, tables, SmartArt graphics, etc.
by applying sound effects.
2. Transitions are motion effects that
when in Slide Show view add
movement to your slides as you
advance from one slide to another.
There are many transitions to choose
from, each one of which allows you to
control the speed and even add sound.
3. You have perform following steps to
insert your own sound in a presentation:
v Click the Record button and start
reading your script.
v Click the Stop button when you want
to pause recording: click the Record
button to resume recording.
v You can click the Play button at any
time to play back what you have
recorded so far. Notice that the
dialog box notes how many seconds
your recording lasts.
v Click the OK button in the Record
Sound dialog box when you have
finished recording the narration for
you slide.
v The Audio icon appears on your
slide to show that your slide is
accompanied by an audio file.
4. To insert pictures and Clipart in
presentation:
v Open the PowerPoint presentation
you will add the clip art to.
v Click the “Insert” tab and select Clip
Art from the Images group. A Clip
Art pane will appear.
v Enter the keyword of the clipart you
will insert in the Search For field.
v Choose the collection you will search
for the clip art in the Search In dropdown menu.
v Open the Results Should Be dropdown menu. Select the clipart you
will insert. Clipart
v Click the image in the Clip Art pane
to insert it in the slide.
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5. To import data from word file follow
the steps given below:
v Click on the View tab and select the
Slide Sorter button.
v Now click on the New Slide dropdown menu on the Home tab. Select
the Slides from Outline option.
v The Insert Outline dialog box will
appear. Browse the location of the
Word file.
v Select the file and click on the Open
button.
E. 1. Mohit need to use Transition Effects to
link every slide to its succeeding slide.
2. See Q. D.5.
CH-5 MICROSOFT EXCEL 2016
Exercise
A. 1. F4, 2. Ctrl+C, 3. Format, 4. Ctrl+F9,
5. Enter, Cancel, 6. 15 and 8.43,
7. End,
B. 1. True, 2. False, 3. False, 4. True,
5. False, 6. False, 7. False.
C. 1. (c), 2. (b), 3. (c), 4. (a), 5. (a), 6. (b),
7. (a).
D. 1. Using Edit Mode
v Select the cell D6. Double-click on
the cell.
v The insertion point will blink within
the cell.
v Note that the Edit mode is

displayed on the left side of the
pointer at the desired place and
modify the contents.
v Press the Enter key. The changes will

be entered in the current.
v Observe, the Edit mode indicator

modifies to Ready mode.
2. Inserting a Column/Row
v Select the column or cell to the left of

which a new column is to be inserted.
Here, we have selected column 'E'.
v Click on the drop-down arrow of the
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Insert button in the Cells group on
the Home tab and select the Insert
Sheet Columns option. Excel inserts
a blank column to the left of column
'E' and shifts the entries of column 'E'
to column 'F'.
v Similarly you can insert a row as you
insert a column. Select the row or a
cell above which a new row is to be
inserted and choose insert sheet
Rows from the options of Insert
drop-down menu.
3. v After making changes in a cell, you
may want to cancel the changes and
retrieve the earlier data. To undo the
last action (s) done, use the Undo
button on the Quick Access Toolbar.
v The Redo command is used to
quickly repeat the last action (s) that
you have undone using Undo
command. To do so, click on the
Redo button on the Quick Access
Toolbar.
4. Copying and Pasting Data
v Select the cell or a range of cells you
require to copy. Let us say B4:D4.
v Click on the Copy button in the
Clipboard group. The dashed line
will display around the selected cells.
v Select the destination cell, let us say
F6 and click on the Paste button in
the Clipboard group. The text will be
copied to the new location.
v If you want to paste the same data
many times, you require to click on
the Paste button in different cells.
5. Do the following steps using Drag and
Drop method:
v Select a cell or a range of cells. Place
the mouse pointer at the edge of the
selected cells.
v Observe that the pointer turns from
a white cross symbol to a move
pointer symbol +.
Keys Computer (6-8)

v Drag the selected cell or a range of

cells to a new destination and release
the mouse button. The data will be
moved to a new location.
6. Data can be moved by using following
steps :
v Right-click on the cell to open
v Shortcut menu and choose the Cut
command.
v Now, select the destination cell, rightclick on it and select Paste option.
7. Flash Fill is a time-saving feature of MS
Excel, which recognises the data fill
pattern that you use repeatedly in a
worksheet and then fills the unfinished
series accordingly.
Let us try it practically.
v Make two columns, NAMES and
INITIALS, in the Excel sheet.
v Fill the data in NAMES column as
shown in the figure.
v The INITIALS column should have
data that is a combination of the first
letters of first name and the Last
name, Like RK for Ravi Kumar.
v Type RK in the INITIALS column
and press Enter key.
v Click on the Fill drop-down arrow
located on the Home tab in the
Editing group and select the Flash Fill
option. You can also use the shortcut
key Ctrl + E.
v The initials of the remaining entries
will be automatically added to the
cells of the INITIALS column.
8. To modify the row Height
v Select the row.
v In the cells group on the Home tab.
Click on the drop-down of arrow the
Format button.
v Click on the Row Height option.
v The Row Height dialog box displays.
Enter the required value and click
OK.
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v The change will be shown on the

v Select both rows and place the

selected row.
To modify the Column Width
v Select the column.
v Click on the drop-down arrow of the
Format button on the Home tab.
From the displayed list of options,
click on Column Width.
v The Column Width dialog box
displays. Enter the required value
and click OK.
Notice the change on the selected
column.
9. The Auto Fill is the easiest way to fill
data automatically in the worksheet
cells. Do the following steps to fill data
automatically in the worksheet cells.
v Type 'January' in cell B1.
v Place the pointer at the lower right
corner of the cell.
v The mouse pointer turns into a black
"+" cross symbol.
v Hold down the left mouse button
and drag the fill handle up to cell B5.
Release the button.
v The months February to May would
display in the cells B2 to B5.
E. 1. Manish need to perform following
steps to insert a new column:
v Select the column or cell to the left of
which a new column is to be inserted.
Here, we have selected column 'E'.
v Click on the drop-down arrow of the
Insert button in the Cells group on
the Home tab and select the Insert
Sheet Columns option. Excel inserts
a blank column to the left of column
'E' and shifts the entries of column 'E'
to column 'F'.
2. Manjit can use Auto Fill to finish his
assignments quickly. He need to
perform following steps:
v Type 1' in cell B1 and Type 2 in B2.

pointer at the lower right corner of
the cell.
v The mouse pointer turns into a black
"+" symbol.
v Hold down the left mouse button and
drag the fill handle up to cell B100.
Release the button.
v The counting 1 to 100 would display
in the cells B1 to B100.
3. A . D4 = B4 + C4
D6 = B6 + C6
D9 = D4 + D5 + D6 + D7 + D8
B. B2
C. C8
D. Enter.
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CH-6 FORMULAS AND FUNCTIONS
Exercises
A. 1. calculation, 2. Equal to (=),
3. Cell reference, 4. Absolute reference,
5. Concentration, 6. Arguments,
7. Parenthesis, 8. &.
B. 1. True, 2. True, 3. True, 4. True, 5. True,
6. True, 7. True, 8. True.
C. 1. (a), 2. (c), 3. (c), 4. (a), 5. (b), 6. (a).
D. 1. Formulas are the user defined
instructions to perform arithmetical
calculations, whereas, Functions are
the pre-defined on in built formulas
that come with Excel.
A formula forms a relationship
between two or more cells. It is an
expression that can incorporate cell
addresses, numbers arithmetic
operators, and parenthesis. You can
perform simple as well as complex
calculations using formulas.
Let us use it to calculate the sum of the
numbers in B4, B5, and display the
result in B11.
Follow the steps given below to use a
formula:
v Click on the cell B11 (where you
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want to show the result) and type =
sign.
v Click on the cell B4. A dashed border
called marquee will display around
it. Its address will display in the B11
and in the Formula bar. This process
of clicking on the cell to add its
reference to a formula is known as
Pointing. The Status bar will exhibits
the status of Point.
v Now Type the + symbol.
v Repeat the above steps till B9 or type:
= B4 + B5 + B6 + B7 + B8 + B9 in B11.
You will observe the different color
borders that display around these
cells.
v Press the Enter key. Cell B11 will
show the total of all the values from
B4 to B9.
2. There are four types of cell reference:
(i) Relative Reference, (ii) Absolute
Reference (iii) Mixed Reference,
Circular Reference.
(i)Relative Reference : By default, all
cell references are relative references.
When copied across multiple cells,
they change based on the relative
position of rows and columns. For
example, if the formula in A3 is = A1
+ A2 and you copy the formula from
A3 to B3. Excel automatically changes
the reference to match the position of
cells, i.e., = B1 + B2 .
(ii) Absolute Reference : There may be
situations when you do not want a cell
reference to change when filling cells.
Unlike relative references, absolute
references do not change when copied
or filled. You can use an absolute
represent to keep a row and/or column
constant. An absolute reference is
designated in a formula by the addition
of a dollar sign $. It can precede the
column reference, the row reference or
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both. For example = $A$1+$A$2 To create
andcopyaformulausingabsolutereferences:
3. Ways of entering a cell reference in a
formula:
Using Copy-paste Option:
v Click on the button New Sheet present
to the right of the Sheet 1 tab at the
bottom of the screen. A new worksheet
with the name Sheet 2 will be added.
Now, enter the data as shown in the
Figure.
v Click on the Sheet 1 tab. Now, click
on cell B11 where the 'SUM' function
is used.
v Copy the formula using Ctrl+C.
v Click on the Sheet 2 tab. Click on
the cell B11. Now, paste the formula
using Ctrl + V. The cell will display
the result of the formula i.e.,
summation of the cell values.
Using Sheet Reference
In this method, we use sheet number,
exclamation mark, and cell address to refer
to a cell a particular worksheet. For
example, by writing Sheet1! D4, we are
referring to the cell D4 of Sheet1. Let us try
to use this method to calculate the total
salary.
v Click on the cell C4 of Sheet 2.
v Type = B4 +Sheet1:D4 in it and press
Enter. This will add the 'Incentive
Amount' present in the cell D4 of
Sheet1 with the 'Salary' present in
cell B4 of Sheet2.
4. To rename a worksheet do the
following steps.
v Right-click on the 'Sheet2' tab in the
worksheet.
v A shortcut menu will appear. Click
on the Rename option.
v The Sheet tab gets highlighted. Type
the new name and press Enter.
v Note that the name of the Sheet2 gets
changed.
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Today ( ) : It is used to show the current
date.
8. Rules To Enter A Function
v All Excel functions must start with =
sign.
v Function name must be a valid Excel
name. For example, SUM, AVERAGE.
v Function name must be followed by
an opening and closing parenthesis.
6. A formula in a cell that directly or
indirectly refers to its own cell is
v Arguments are enclosed in the
called a circular reference. For
parenthesis. For example; = SUM
example, if you enter the formula =
(A1:A5).
A1 + A2x3 in cell A2, you are making
9. Steps to find the GCD of three numbers:
the formula to refer to its own cell
v Enter three integers in cell A1, A2,
value, which is not possible. In such a
and A3.
case, an alert dialog box indicating
v Now, select the cell A4 where the
the problem displays as shown in the
GCD of these numbers will be
figure given below. As soon as you
exhibited.
click on the OK button of the alert
v Click on the Math & Trig drop-down
dialog box, 0 will be returned in the
button in the Function Library on
cell containing formula. The Status
the Formulas tab and select GCD
bar will also notify you that circular
from the displayed list of options.
reference is found in the workbook
v The Function Arguments dialog box
and the address of that cell will be
comes into sight. Type A1, A2 and
displayed on it.
A3 in Number1, Number2, and
Number3 text boxes respectively.
7. Uses of common functions:
Notice that the result of the formula
Autosum: Besides being the common
emerges near the bottom of th dialog
and the fastest way to find numbers
box.
in a range, the Autosum option also
v Click OK. The output will come into
be used like Average, Count, Max,
view in the cell A4.
Min, etc. This option is available in
E. 1. Saurav have to use Max () and Min ( )
two places :
functions to achieve the task.
v In the Editing group on the Home
2. Step 1 : In A2, type the header With
tab.
10% increase. Since we have a number
v In the Function Library group on the
mixed with text, Excel will treat the
Formula tab.
entire cell as text.
Average ( ) : The Average function
Step 2: Press Tab, then in B18, enter
returns the average of the range values.
this Excel percentage formula: =A2 *
The arguments can be a range of cells,
1.10
simply numbers, or numbers along
Alternatively, you can enter the
with cell reference (s).
formula this way: =A2 * 110%
Max (): It is used to find the largest
The Amount is 16150.
value in the given range.
5. Functions are the pre-defined formulas or
built-in calculations. Functions save time
and stop the chance to write wrong
formulas. They accept Arguments and
return Values. Functions start with the equal
to (=) sign followed by the function name
and then the list of arguments separated by
comma within the parenthesis.
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CH-7 USING EXCEL AS DATABASE
Exercises
A. 1. organized, 2. data form, 3. Field name,
4. Consolidation, 5. criteria
B. 1. True, 2. True, 3. True, 4. False, 5. False
C. 1. (b), 2. (a), 3. (c), 4. (a), 5. (b)
D. 1. A database is an organized collection
of data. It is a collection of schemes,
tables, queries, reports, views and
other elements. It is an electronic
system that allows data to be easily
accessed, manipulated and updated.
In other words, a database is used by an
organization as a method of storing.
Managing and retrieving information.
2. Rules to enter the Field Names:
v Field names have to be unique.
v You can space out the title of the field
and it will still find the topic eg.
v If a label field has no name, it will not
be shown when the form is viewed,
only when it is edited.
v Field names can in theory include any
text, but you should stick to alpha
numeric characters.
v Leading and trailing spaces are not
significant.
3. Sorting is the process of arranging data
into meaningful order so that you can
analyze it more effectively. We can sort
data according to a particular. Field
either in increasing or decreasing order
in a worksheet.
4. v The excel feature “filter” is a very
important feature as it saves time and
reduces workload by many times
especially for those who use excel all
day.
v It is used everyday mainly for analysis
work. Filters are used to find all records
matching a certain criteria at one place.
v There are different types of filter in
Excel such as number filter, text filter,
begins with, end with, contains, display
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top 10.
v The benefits of filters (save time and

reduces workload) increase
exponentially when there are more
than one or two criteria of you have
50,000 transactions items and suppose
the type of transaction items and
suppose the type of transaction that
you look for only 5 to 10 in number,
instead of searching manually you can
use “Filters”.
5. Data Validation is used to restrict the
cell entries within a specified range.
v Select the range E5:E13. Choose Data >
Validation. Click the Setting tab.
v In Allow: drop-down list box, select
Whole number option.
v In Data drop-down list box, between
option is selected by default.
v In Minimum: text box, type 0 and in
Maximum: text box type 100.
v Click the Input Message tab. In Title:
text box, type Validation. In Input
message: box, type >=0 and <=100.
v Click the Error Alert tab and type
'Input is wrong' in Error Message box.
Click OK to close the dialog box.
v If you try to enter data beyond the
specified limit in the selected range, an
error message will be displayed. Click
on Retry to enter another value in the
cell.
6. A pivot table is a program tool that
allows you to recognized and
summarize selected columns and rows
of data in a spreadsheet of database
table to obtain a desired report. A pivot
table doesn’t actually change the
spreadsheet or database itself.
7. Sorting takes a set of data and sorts it by
a chosen metric or letter. The most
important difference is that sorting
does not remove entries from the data
set. Sorting only puts the data into a
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new order.
8. Filtering on the other hand is useful in
a different way. While sorting will give
you the option of choosing which
metric you want to prioritize. Filtering
actually removes data that’s irrelevant
to your analysis.
E. Riya will make worksheets in group by
using given steps.
v Create a new workbook. The 'Sheet1'
worksheet is active.
v Press and Hold the Shift key. Click on
Sheet3 Tab.
v Release the Shift key. Note that all the
three worksheet tabs have become
white and the word '[Group]' appears
in the Title bar. It indicates that Sheet1,
Sheet2 and Sheet3 are grouped
together.
v Enter the data as shown in the figure, in
the grouped worksheet.
v Format the heading by making it bold
and increasing its font size to 18. Apply
border around the heading 'FIRST
QUARTER SALES' 2016.
v Select the Row 3, increase the Font size
to 14 and bold it. Similarly, select
Column A and apply same formatting
effects.
v To ungroup the worksheet, click on any
other Sheet tab except Sheet1 or right
click on any grouped Sheet tab and
select Ungroup Sheets option.
v All the three sheets will display the
common data with formatting effects.
v Click on Sheet2 and change the year to
2017 Similarly, change the heading to
" C O N S O L I DAT I N G F I R S T
QUARTER SALES (2016 - 2017)" in
Sheet3.
v Save the worksheet with the name
"MULTIPLE"

12

CH-8 WORKING WITH FLASH CS6
Exercise
A. 1. Symbol, 2. Library, 3. Three, 4. Button,
5. Morphing, 6. Instance, 7. two
B. 1. False, 2. True, 3. False, 4. False, 5. False,
6. True, 7. False
C. 1. (c), 2. (b), 3. (c), 4. (b), 5. (b)
D. 1. A symbol is reusable static image that
are used mainly to create animations.
The three types of symbols
Graphic Symbols : They are reusable
static images that are used mainly to
create animations.
Button Symbols : These symbols are
used for time line navigation.
Movie clip Symbols : These symbols
are reusable pieces of flash animation.
2. Follow these steps to create a symbol:
v Draw a car on the Stage, by using the
Rectangle Tool , Oval Tool , Pencil Tool
and , from the Tools panel.
v Choose the Selection Tool and drag the
mouse pointer on the Stage to enclose
the car within a rectangular selection
marquee.
v Choose Modify > Convert to Symbol.
v You will get a Convert to Symbol dialog
box. Choose Graphic from the Type
drop down list.
v Specify the symbol's name - G-Car
Name textbox and click OK. Your new
symbol is now added in the library
panel.
3. An animation is the illusion of
movement created by showing a series
of still pictures in rapid succession. In
the world of computers, graphic
software used to create this effect.
4. Instance is a copy of the original
symbol. Which can have use own
independent properties such as color,
size, function etc, different from the
original symbol.
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5. Motion guides are especially useful
when you work with a shape that has an
obvious orientation (or direction, such
as the nose of a car or an airplane). For
this reason, be sure to use a symbol
with an obvious orientation.
6. Any object (or group of objects) that
can appear on the stage can be made
into a symbol. Here’s how to do it:
v Select one or more objects on the stage.
The selected objects may include
paths, text objects, bitmaps, or even
other symbols.
v Choose Modify > Convert to Symbol,
or press the F8 key. The Convert to
Symbol dialog box appears.
v Enter a name for the symbol into the
Name field.
v Click the radio button for the type of
symbol you want to create: a movie
clip, button, or graphic.
7. Animations can be created in Flash
with the help of tweening, which
means 'in between'. The movement
from one keyframe to the other
becomes well timed with the use of the
tweening. There are two types of
tweened animation.
v Motion tween
v Shape tween
The main difference between both the
tweening is that the Motion tweening
works on symbols, whereas, shape
tweening is used with objects that are
not symbols and are ungrouped.
8. The Deco Tool has a symmetry brush,
which enables you to create interesting
textures, patterns and symmetrical
drawings from symbols. It provides
several distinctive effects, which can
either be applied to the entire stage or
any object that is selected on the stage.
9. The spray Brush tool paints with
instances allows you to brush pattern
of shapes at one time. By default, it
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emits a spray of dot particles using the
currently selected Fill Color. However,
it can also be used to apply a symbol as a
pattern.
E. 1. Sohail need to use shape tween
animation to show a smiling face
changing into a crying face.
2. Mohini need to do following steps to
move the clouds:
v Open the saved file.
v Notice that the layer structure matches
the Clouds demo. In fact, you may use
your Cloud file in this exercise if you
prefer.
v Add a new layer and name it clouds.
v Select the new layer and open the
Library. Drag 2-3 instances of clouds
onto the first keyframe of the new layer.
v Single-click on the cloud instances (to
select them) and add a Motion Tween
(by right-clicking or choosing Insert >
Motion Tween from the Menu).
v Flash just added the default number of
frames for a new Tween (about 24).
Drag the playhead to frame 12 (or
about half way to the end of the
animation). Now, position the clouds
about halfway across the screen.
v To complete the second part of the
animation drag the play head to the last
frame and reposition the clouds once
again.
v When you run the movie, you might
decide that it is moving too quickly. By
adding more frames, the animation
will take more time.
v Adjust your animation until you are
satisfied! Test the movie to watch your
animation.
CH-9 THE MAIL MERGE
Exercises
A. 1. Main, 2. MS Excel or MS Access, 3.
Modify, 4. Many, 5. MS Word
B. 1. True, 2. True, 3. False, 4. True, 5. True, 6.
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True, 7. False, 8. False
C. 1. (b), 2. (a), 3. (b), 4. (a), 5. (b)
D. 1. The body of the standard letter to be
sent to all recipients is called the Main
Document as shown in the figure given
below. It also contains the required
field names for carrying out the merge
process. Data Source as shown in the
figure stores information to be brought
into the main document. It is also
called the data file. The data file has a
table comprising columns for each
field of information.
2. Once you have selected the type of mail
merge, you can make your recipient list
or data source. Apart from creating it
in MS Word, you can import it from
MS Excel or MS Access database.
3. Mail merge is used to create letters, email messages, envelopes, labels and
directories. The data document holds
the text that repeats for all merged
documents. Click on start Mail Merge
and select the document type on the
mailing tab as shows in the figure.
4. The process of mail merge includes
three main steps.
v Creating the main document
consisting the body of the letter.
v Creating the data source that
comprises the records of recipients.
v Merging the data source and the main
document.
5. Click on the Preview Results button in
the Preview Results group of the
Mailings tab. It enables you to navigate
through the recipients in the data
document.
E. 1. It also contains the required field
names for carrying out the merge
process. Data Source as shown in the
figure stores information to be brought
into the main document. It is also
called the data file. The data file has a
table comprising columns for each
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field of information. For example, it
may store names of people, their
addresses and alike information. It has
some variable data such as first name,
last name of a recipients and the postal
pin code of the place he/she belongs to.
The header row is the first row of the
table. It records collection of variable
data regarding a person or a thing.
2. The different steps to choose your
recipients are given below. Click on
the Select Recipients button from the
Start Mail Merge group of the
Mailings tab. A drop-down menu
comprising different options emerges.
CH-10 INTERNET SERVICES
Exercises
A. 1. Internet, 2. Web browser, 3. Skype, 4. Elearning, 5. Internet Radio
B. 1. False, 2. True, 3. False, 4. True, 5. True
C. 1. (b), 2. (c), 3. (c), 4. (b), 5. (a)
D. 1.They devised a network of four
computers to exchange and share their
data.
2. BSNL, Tata, Airtel, Reliance
3. The only difference between Instant
messaging and Online chat is that in
Instant messaging (IM), the
communication come about between
known users, and involves only those
people whom the user has invited,
whereas, Online chat could happen
between unknown users too.
4. E-learning can be implemented using
an Internet connection, a network, an
intranet, or a storage disk. It is less
expensive than traditional learning
and can be used to give training to a
large group of students at the same
time, in an interactive and interesting
manner. Thus it saves time and lowers
the need for costly classroom-based
training.
5. Internet Radio, is an online radio
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service that is broadcasted over the
Internet on dedicated radio servers. It
is broadcasted in much the same way as
traditional radio with regard to its
presentation and format. Here, audio
stream is digitized and split into small
pieces for transmission across the
Internet. It provides the listeners with a
continuous stream of audio, which
cannot be paused or replayed.
E. 1. This technology is largely used for
virtual meetings among a group of
people to discuss political, business,
medical, or social affairs. On television
most often we see that a program host is
conducting interview among several
participant sitting in different cities and
countries. This is done through video
c o n f e r e n c i n g . Po p u l a r Vi d e o
conferencing applications include:
Skype, Adobe Connect, Oovoo, Yugma,
Ekiga, etc.
2. It is a net banking service that allows
customers to perform all routine
transactions such as account transfers,
balance enquiries, bill payments and
stop payment requests, and some
even offer online loan and credit
applications. These transactions can
be performed from anywhere
regardless of time, if one has an
Internet connection on his computer.
As all the services are web enabled,
the customer needs to log in to the
website of a bank and access the
centralized database by stating the
desired bank service.
My Activity Question
MODEL TEST PAPER-1
A. 1. (b), 2. (b), 3. (a), 4. (b), 5. (c)
B. 1. Machine, 2. Disk Clean Up, 3. start/stop,
4. copying, 5. Add level
C. 1. True, 2. False, 3. True, 4. True, 5. False
D. 1. A computer language includes various
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languages that are used to communicate
with a computer machine. Some of the
languages like programming language
which is a set of codes or instructions
used for communicating the machine.
Machine code is also considered as a
computer language that can be used for
programming.
2. Start/Stop Symbol: This symbol is used
to show where your flow begins or ends.

Input/Output Symbol: This symbol is
used to indicate the acceptance of
inputs from a user or the output or the
result concluded.

Flow Lines: The flowchart symbols are
connected with the help of flow lines.

Processing Symbol: his symbol is used
to illustrate a process, action or an
operation.

Decision Box: his symbol is used in a
process flow to as a question. And the
answer to the question determines the
arrows coming out of the symbol.

Connector: In flowcharts, this symbol
is typically small and is used as a
connector to show a jump from one
point in the process flow to another.
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3. Advantages of flowcharts :
v Communication: Flowcharts are
better way of communicating the logic
of a system to all concerned or
involved.
v Effective Analysis: With the help of
flowchart, problem can be analyzed in
more effective way therefore reducing
cost and wastage of time.
v Proper Documentation: Program
flowcharts save as a good program
documentation, which is needed for
various purposes, making things more
efficient.
Disadvantages of Flowcharts
v Complex logic: Sometimes, the
program logic is quick complicated.
In that case flowchart becomes
complex and clumsy. This will
become a pain for the user, resulting
in a waste of time.
v Alterations and Modifications: If
alternations are required the flowchart
may require re-drawing completely.
This will usually waste valuable time.
v Reproduction: As the flowchart
symbols cannot be typed, reproduction
of flowchart becomes a problem.
4. Windows Media Player is a media
player and media library applicator
developed by Microsoft that is used for
playing audio, video and viewing
images on personal computer running
the Microsoft Windows Operating
System, as well as on pocket PC and
windows Mobile based devices.
E. 1. Machine Language: Machine language
is a low level programming language. It
is the first generation language
developed for communicating with a
computer. It is written in machine code
which represents 0 and 1 binary digits
inside the computer string which
makes it easy to understand and
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A.
B.
C.
D.

perform the operations.
2. Features of Windows 10 : Windows 10
is loaded with multi-tasking tools such
as custom start menu, live tiles, snap
assist, task view and virtual desktops to
keep you organized focused and ready
for anything.
3. High Level languages : The High
level languages are the most used and
also more considered programming
languages that helps a programmer to
read, write and maintain. It is also the
third generation language that is used
and also running till now by many
programmers.
4. Flowchart: A flowchart is a type of
diagram that represent an algorithm,
workflow or process showing the steps
as boxes of various kinds and their
order by connecting them with arrows.
This diagrammatic representation
illustrates a solution model to a given
problem.
5.4GL: Fourth generation computer
languages are closer to human language
than other high-level languages and are
accessible to people without formal
training as programmers.
MODEL TEST PAPER-2
1. (b), 2. (c), 3. (c), 4. (c), 5. (a)
1. Transitions, 2. Text, Object, 3. Format,
4. Concentration, 5. Arguments
1. True, 2. False, 3. False, 4. False, 5. True
1. Rules To Enter A Function
v All Excel functions must start with =
sign.
v Function name must be a valid
Excel name. For example, SUM,
AVERAGE.
v Function name must be followed by
an opening and closing parenthesis.
v Arguments are enclosed in the
parenthesis. For example; = SUM
(A1:A5).
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2. v After making changes in a cell, you
charts, logos, etc. that are made up of a
may want to cancel the changes and
sequence of images displayed after this
retrieve the earlier data. To undo the
other on the slide are called Animations.
last action (s) done, use the Undo
button on the Quick Access Toolbar.
Animation is quite helpful when you
want to focus on important points. It
v The Redo command is used to
also controls the sequence of the flow
quickly repeat the last action (s) that
of information and helps in making
you have undone using Undo
information more extraordinary.
command. To do so, click on the
Apart from giving visual effects to your
Redo button on the Quick Access
presentation, you can also sizzle up
Toolbar.
your slide objects – the text, pictures,
3. Ways of entering a cell reference in a
shapes, tables, Smart Art graphics, etc.
formula:
by applying sound effects.
Using Copy-paste Option:
To modify the row Height
v Click on the button New Sheet
v Select the row.
present to the right of the Sheet 1 tab
v In the cells group on the Home tab.
at the bottom of the screen. A new
Click on the drop-down of arrow the
worksheet with the name Sheet 2 will
Format
button.
be added. Now, enter the data as
v
Click
on
the Row Height option.
shown in the Figure.
v
The
Row
Height dialog box displays.
v Click on the Sheet 1 tab. Now, click
Enter
the
required value and click
on cell B11 where the 'SUM' function
OK.
is used.
v The change will be shown on the
v Copy the formula using Ctrl+C.
selected row.
v Click on the Sheet 2 tab. Click on the
To modify the Column Width
cell B11. Now, paste the formula
v Select the column.
using Ctrl + V. The cell will display
v Click on the drop-down arrow of the
the result of the formula i.e.,
Format button on the Home tab.
summation of the cell values.
From the displayed list of options,
Using Sheet Reference
click on Column Width.
In this method, we use sheet number,
exclamation mark, and cell address to
v The Column Width dialog box
refer to a cell a particular worksheet.
displays. Enter the required value
For example, by writing Sheet1! D4, we
and click OK.
are referring to the cell D4 of Sheet1.
Notice the change on the selected
Let us try to use this method to
column.
calculate the total salary.
E. 1. Animation Effects: Moving objects,
v Click on the cell C4 of Sheet 2.
such as text, graphics, charts, logos,
v Type = B4 +Sheet1:D4 in it and press
etc. that are made up of a sequence of
Enter. This will add the 'Incentive
images displayed after this other on
Amount' present in the cell D4 of
the slide are called Animations.
Sheet1 with the 'Salary' present in
2. Formula Errors: If any formula is
cell B4 of Sheet2.
entered incorrectly in MS Excel, then
4. Moving objects, such as text, graphics,
Excel shows an error message rather
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document.
than the proper value. It also helps
5. Sorting is the process of arranging data
you in finding and solving the
into meaningful order so that you can
problem.
analyze it more effectively. We can sort
4. Redo features: The Redo command
data according to a particular. Field
is used to quickly repeat the last
either in increasing or decreasing order
action (s) that you have undone
in a worksheet.
using Undo command. To do so,
E.
1.
Adobe Flash is a multimedia software
click on the Redo button on the
platform
used for production of
Quick Access Toolbar.
animations,
rich Internet applications,
5. Video Clips: Video clips are short
desktop
applications,
mobile
clips of video usually part of a longer
applications,
mobile
games
and
recording. They add liveliness to the
embedded web browser video players.
presentation. PowerPoint enables you
Flash displays text, vector graphics
to insert a video onto a slide and play it
and raster graphics to provide
during your presentation.
animations, video games and
MODEL TEST PAPER-3
applications.
It allows streaming of
A. 1. (c), 2. (b), 3. (a), 4. (b), 5. (a)
audio and video, and can capture
B. 1. Symbol, 2. data form, 3. Main, 4. Many,
mouse, keyboard, microphone and
5. MS Word
camera input.
C. 1. True, 2. False, 3. True, 4. False, 5. True
2. Flash provides us with the ability to
D. 1. Motion guides are especially useful
create a motion guide that specifies the
when you work with a shape that has an
path of the movement for an object.
obvious orientation (or direction, such
Instead of having an object move from
as the nose of a car or an airplane). For
one point to another in straight path, we
this reason, be sure to use a symbol
can make it follow an arbitrary path that
with an obvious orientation.
we draw, i.e. a motion guide.
2. The only difference between Instant
3. Once you have selected the type of mail
messaging and Online chat is that in
merge, you can make your recipient list
Instant messaging (IM), the
or data source. Apart from creating it in
communication come about between
MS Word, you can import it from MS
known users, and involves only those
Excel or MS Access database.
people whom the user has invited,
4. E-Banking stands for Electronic
whereas, Online chat could happen
Banking. It is a net banking service
between unknown users too.
that allows customers to perform all
3. They devised a network of four
routine transactions such as account
computers to exchange and share their
transfers, balance enquiries, bill
data.
payments and stop payment requests,
4. The process of mail merge includes
and some even offer online loan and
three main steps.
credit applications. These transactions
v Creating the main document
can be performed from anywhere
consisting the body of the letter.
regardless of time, if one has an
v Creating the data source that
Internet connection on his computer.
comprises the records of recipients.
As all the services are web enabled, the
v Merging the data source and the main
18
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customer needs to log in to the
website of a bank and access the
centralized database by stating the
desired bank service.
5. Video Call or Video Conference
means to conduct a conference
between two or more participants at
different sites by using computer
network to transmit audio and video
data. The participants can view each
other on their monitors as well as hear
voice over speakers of their laptops or
desktop computers.
It implies the use of camera called Web
cam and also microphone at the end of
each participant to capture video and
audio data in real time. Images and
sounds are transmitted through
Internet and delivered to other
participants.
This technology is largely used for
virtual meetings among a group of
people to discuss political, business,
medical, or social affairs. On
television most often we see that a
program host is conducting interview
among several participant sitting in
different cities and countries. This is
done through video conferencing.
Popular Video conferencing
applications include: Skype, Adobe
Connect, Oovoo, Yugma, Ekiga, etc.
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